View Single Post
  #1  
Old 11-15-2007
RoryBecker RoryBecker is offline
neophyte
 
Join Date: Nov 2007
Posts: 1
RoryBecker is on a distinguished road
Default Cannot switch to "Run as Administrator" application.

I run Vista Ultimate 64-bit on a core2duo with 4Gig of RAM
It all runs very nicely. Save for one issue.

I have issues with both Visual Studio and IIS7 (of at least it's management console) although I suspect the problem is further reaching.

VS is set (using the compatability tab) to "Run as Administrator". This triggers UAC when it loads. Which I happily accept.

IIS7 already requires a UAC confirmation when it launches.

And now to the problem.

Load wither of these 2 apps and maximise it (the Maximise step is not strictly nessecary). Then load something which does not require UAC confirmation. like Notepad.



So Now you have notepad in the foreground and a UAC Elevated Application maximised in the background.

Try to switch to the Elevated Application by clicking it's window in the background.

The window responds to mouse hovers and such like but will not respond to the attempt to bring it to the foreground by clicking directly on it.

You have to either use Alt-Tab or click directly on the task-bar button for the app.

It's as if the 2 sets of applications (elevated and non elevated) are running in 2 distinct desktops. with the non elevated desktop not having any clue about the elevated desktop.

Can anyone help me?

This is REALLY annoying

Thanks
Reply With Quote