Go Back   Vista Help Forum » Windows Vista » Vista Help Forum
Reply
 
Thread Tools Display Modes
  #1  
Old 11-02-2008
mfwills mfwills is offline
neophyte
 
Join Date: Nov 2008
Posts: 2
mfwills is on a distinguished road
Default Multi-platform network problem

I have a home network consisting of a Macintosh desktop (M-Desk) running OSX, a Compaq laptop (C-Lap) running XP Home and a Compaq desktop (C-Desk) running Vista Home Premium, supposedly all connected via a Linksys WRT54G router. M-Desk is wired to the router, the other two are wireless. All three do their internet things just fine.

C-Lap and M-Desk see each other on the network and can access files. M-Desk sees C-Desk and can access files in the Public folder.

C-Desk and C-Lap do not see each other on the network at all. C-Desk sees M-Desk, but cannot connect. When I enter the user name and password that work properly from C-Lap, C-Desk inserts its own logged-on user and a backslash in front of what I entered, which seems to me is the reason it returns a login error.

Absent other info, it appears to be a Vista problem. C-Desk replaced a WXP Home desktop which had no problem connecting to the other two.

This partial connectivity is, to say the least, somewhat annoying, especially since we had full connectivity pre-Vista. I want all three boxes to see each other and be able to access files. Can anyone offer anything?



Matt

Last edited by mfwills; 11-02-2008 at 08:35 AM. Reason: Goofed.
Reply With Quote
  #2  
Old 11-02-2008
cyclic's Avatar
cyclic cyclic is offline
Agent - Level 3
 
Join Date: May 2008
Location: Cheshire
Posts: 751
cyclic is on a distinguished road
Default

It not only appears to be a Vista problem, it is, unfortunately I can offer no words of wisdom other than searching MS knowledge base or technet, it has to be said though that even those august bodies of technical enlightenment are still struggling with the problem of multiple connections when Vista is introduced.
There was one instance that I did fix, which I think was as much good luck as good management, on the Vista machine I removed the IPV6 and tunneling protocols and in order to get rid of WAP, which appeared to be a major problem, I installed the latest XP driver for the Broadcom device.....worked and still does like a charm. However trying it since on another similar set up got nowhere.
Reply With Quote
  #3  
Old 11-02-2008
mfwills mfwills is offline
neophyte
 
Join Date: Nov 2008
Posts: 2
mfwills is on a distinguished road
Default

I guess in light of my wife (primary user of C-Desk) absolutely HATING Vista and anxiously awaiting Windows 7 in hopes that it will work better, perhaps I should just be satisfied with what I have for the moment. I can, after all, get and put from M-Desk to C-Desk, which is the most important route.

Thanks.
Reply With Quote
  #4  
Old 11-02-2008
BurrWalnut BurrWalnut is offline
Member - Class 1
 
Join Date: Sep 2008
Location: London, England
Posts: 60
BurrWalnut is on a distinguished road
Default

You haven't said exactly what you have tried, so I’m offering these suggestions:

ALL MACHINES
Put all the computers in the same workgroup.

Windows firewall is normally set to allow file and printer sharing but if you have a third-party firewall make sure file and printer sharing is enabled so that each machine can talk to the other(s). Don’t disable the Windows firewall if it’s the only one you’re running.

VISTA MACHINE
Go to Control Panel > Classic View > Network and Sharing Center and make sure you have Network Discovery, File Sharing and Public Folder Sharing all set to ‘On’ and, if you‘re not using passwords set Password Protected Sharing to ‘Off’, unless you want to set up identical usernames and passwords on all computers in your network. If you have it on, you will be asked for a username and password when you try to access a Vista computer from an XP computer.

To share a Vista folder, click it > Share on the Toolbar > Advanced Sharing, click ‘Share this folder’ > Apply > OK, etc.

If you don’t have Password Protected Sharing turned on, you have to change the security permissions on your folder to allow 'Everyone' access. Right-click the folder > Properties > Security Tab > Edit > Add and type Everyone (not the quotes) into the box and OK. Tick the boxes next to the permissions you want to allow, then Apply > OK, etc. You may see some screens coming up with message 'Error Applying ……..'. These is normal and can be ignored by clicking Continue.

Two little people should appear on the icons of those that are shared. An alternative way of sharing is to drag the folders you want to share to the Public folder.

XP MACHINE
As you are sharing with an XP machine, you may need to install the Link Layer Topology Discovery (LLTD) responder on the XP machine so that the computer shows up in Vista’s network map, get it here http://www.microsoft.com/downloads/d...displaylang=en

Last edited by BurrWalnut; 11-02-2008 at 10:03 AM.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Network Problem navjas73 Vista Help Forum 0 07-01-2010 02:25 PM
multi picture resizer j4ffa Multimedia & Graphics 2 11-13-2008 03:56 AM
Network problem Cubeclub Vista Networking Forum 1 05-07-2008 12:34 PM
vista multi display problem llord Vista Hardware Forum 1 11-24-2007 05:55 AM
Network Problem jbohms Vista Networking Forum 0 11-10-2007 01:18 PM