PHP Warning: mysql_query(): Access denied for user 'vhelpf'@'localhost' (using password: NO) in ..../includes/class_postbit.php(265) : eval()'d code on line 2

PHP Warning: mysql_query(): A link to the server could not be established in ..../includes/class_postbit.php(265) : eval()'d code on line 2

PHP Warning: mysql_num_rows() expects parameter 1 to be resource, boolean given in ..../includes/class_postbit.php(265) : eval()'d code on line 3

PHP Warning: mysql_query(): Access denied for user 'vhelpf'@'localhost' (using password: NO) in ..../includes/class_postbit.php(265) : eval()'d code on line 2

PHP Warning: mysql_query(): A link to the server could not be established in ..../includes/class_postbit.php(265) : eval()'d code on line 2

PHP Warning: mysql_num_rows() expects parameter 1 to be resource, boolean given in ..../includes/class_postbit.php(265) : eval()'d code on line 3

PHP Warning: mysql_query(): Access denied for user 'vhelpf'@'localhost' (using password: NO) in ..../includes/class_postbit.php(265) : eval()'d code on line 2

PHP Warning: mysql_query(): A link to the server could not be established in ..../includes/class_postbit.php(265) : eval()'d code on line 2

PHP Warning: mysql_num_rows() expects parameter 1 to be resource, boolean given in ..../includes/class_postbit.php(265) : eval()'d code on line 3

PHP Warning: mysql_query(): Access denied for user 'vhelpf'@'localhost' (using password: NO) in ..../includes/class_postbit.php(265) : eval()'d code on line 2

PHP Warning: mysql_query(): A link to the server could not be established in ..../includes/class_postbit.php(265) : eval()'d code on line 2

PHP Warning: mysql_num_rows() expects parameter 1 to be resource, boolean given in ..../includes/class_postbit.php(265) : eval()'d code on line 3

PHP Warning: mysql_query(): Access denied for user 'vhelpf'@'localhost' (using password: NO) in ..../includes/class_postbit.php(265) : eval()'d code on line 2

PHP Warning: mysql_query(): A link to the server could not be established in ..../includes/class_postbit.php(265) : eval()'d code on line 2

PHP Warning: mysql_num_rows() expects parameter 1 to be resource, boolean given in ..../includes/class_postbit.php(265) : eval()'d code on line 3

PHP Warning: mysql_query(): Access denied for user 'vhelpf'@'localhost' (using password: NO) in ..../includes/class_postbit.php(265) : eval()'d code on line 2

PHP Warning: mysql_query(): A link to the server could not be established in ..../includes/class_postbit.php(265) : eval()'d code on line 2

PHP Warning: mysql_num_rows() expects parameter 1 to be resource, boolean given in ..../includes/class_postbit.php(265) : eval()'d code on line 3
Sidebar Error (Black Clock) - Vista Help Forum

Go Back   Vista Help Forum » Windows Vista » Vista Features Forum » Vista Gadgets
Reply
 
Thread Tools Display Modes
  #1  
Old 12-17-2008
tidefan211 tidefan211 is offline
neophyte
 
Join Date: Dec 2008
Posts: 3
tidefan211 is on a distinguished road
Default Sidebar Error (Black Clock)

My Windows Sidebar is having issues. Most of the gadgets display as white boxes, and the clock is just a black circle.



When did the problem start? A couple days ago.
What have you tried to fix it? I googled it and found where someone had reported the same thing on another board. Someone suggested this:
Quote:
This behavior is observed if the XML registration is missing in the system.
To fix the problem, use the following steps:

Close Windows Sidebar. To do so, right-click on the Sidebar icon in the
Notification area and click Exit
Open an elevated Command Prompt window. To do so, click Start, click All
Programs, click Accessories, right-click Command Prompt, and then click Run
as administrator.
In the Command Prompt window, type the following and press ENTER:
regsvr32 msxml3.dll

Similarly, run these commands:

regsvr32 scrrun.dll

regsvr32 jscript.dll

If the registration was successful, you'll see the message DllRegisterServer
in <filename> succeeded for each command executed. Open Windows Sidebar
(sidebar.exe) and check if the problem is resolved.

--------------------------------------------------

1. Open a command prompt by being Administrator (Right click on Command
Prompt and click Run as Administrator)
2. CD to C:\Program Files\Windows Sidebar ( cd drive letter:\Program
Files\Windows Sidebar )
3. Run these commands in this order:
1. regsvr32 -u sbdrop.dll
2. regsvr32 -u wlsrvc.dll
3. regsvr32 atl.dll
4. regsvr32 sbdrop.dll
5. regsvr32 wlsrvc.dll
It didn't work.
What is the error message (of any)? None.
What was the last thing you did before the problem started? I don't think I did anything immediately before that. I did a registry cleaner a couple days before though. I heard that can cause problems.
What are your system specs? Dell Dimension E520, Vista Home Premium.
Do you have a screenshot?
Reply With Quote
  #2  
Old 12-18-2008
Trooper Trooper is offline
Agent - Level 3
 
Join Date: Nov 2007
Location: Australia
Posts: 603
Trooper is on a distinguished road
Default

Odd. So everything was fine before today then?

First thing I would suggest is Visiting Dell for a driver update for your graphics chip/card (GPU).

You haven't changed any visual settings through the control panel lately have you?
Reply With Quote
  #3  
Old 12-18-2008
tidefan211 tidefan211 is offline
neophyte
 
Join Date: Dec 2008
Posts: 3
tidefan211 is on a distinguished road
Default

I have... The computer installed a Windows Update that skewed my visual settings. That was just a bit before this happened.

But anyway, my sidebar is working now. Everything except the calendar, which is an orange square. I've been having some errors on IE too, but my computer just installed an update for IE, so maybe it's fixed.
Reply With Quote
  #4  
Old 12-19-2008
Trooper Trooper is offline
Agent - Level 3
 
Join Date: Nov 2007
Location: Australia
Posts: 603
Trooper is on a distinguished road
Default

The IE patch was merely a security patch. I doubt that will have any affect.

Done any system maintenance? AV scan? Malware removal? Registry cleaner?
Reply With Quote
  #5  
Old 12-19-2008
cyclic's Avatar
cyclic cyclic is offline
Agent - Level 3
 
Join Date: May 2008
Location: Cheshire
Posts: 751
cyclic is on a distinguished road
Default

Do you know what the purpose of trying to register all those .dlls, without firts checking if they already were registered. I don't know where that suggestion came from but I would be very careful in future about blindly following such instructions, which as I would suspect made no difference, other than that you may now have multiple instances of files registered with the system that don't need to be, or those duplicated instances will cause more problems.

Oddly enough your problems may stem from a simple driver problem which could be cured by either updating your current driver or check with the graphics manufacturer for more reports of similar problems.
Reply With Quote
  #6  
Old 12-19-2008
tidefan211 tidefan211 is offline
neophyte
 
Join Date: Dec 2008
Posts: 3
tidefan211 is on a distinguished road
Default

Quote:
Originally Posted by Trooper View Post
The IE patch was merely a security patch. I doubt that will have any affect.

Done any system maintenance? AV scan? Malware removal? Registry cleaner?
Yeah... a registry cleaner and some driver updates and such. I think the driver update is what skewed my visual settings, but the sidebar error came a little later. Anyway, it's fixed now... I think those drivers may have worked after I restarted.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
help with the clock moham235 Vista Help Forum 0 01-25-2009 05:37 PM
sidebar blue line manic Vista Help Forum 4 10-03-2008 08:48 PM
Black Screen / White Cursor or Black Screen Only after boot synthbent Vista Help Forum 3 08-09-2008 09:37 PM
HELP!! Sidebar activation fails HELP!! raj266 Vista Gadgets 4 03-03-2008 02:49 AM
Best Sidebar Gadgets tcash11 Vista Features Forum 3 09-23-2007 09:43 AM